Marshal Half Stack (TSL-100)...troubleshooting help

Posted by diesel389 on Tue, 03/12/02 - 16:28:42.

Hello:
I own a TSL 100 with the 1960A lead cabinet. Does anyone who owns this amp know what impedance I should be using and whether I should be using the Stereo/Mono switch. Also, which Speaker Jack to I run the speaker cable into. I have been using the 16Ohm jack in Mono. Last time my band played I had the clean volume up to 5 and it was not loud at all. Is this a sign to change my tubes? Thanks!

Jeremy



Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Re: Marshal Half Stack (TSL-100)...troubleshooting help

I kind of know what you are talking about, there are at least 2 TSL-100 factory mods one which would defintely help your problem, so should start from there to see if you have them... I'am not familiar with the cab you have but if you want to give me more info I will try to give a recommendation back.

: Hello:
: I own a TSL 100 with the 1960A lead cabinet. Does anyone who owns this amp know what impedance I should be using and whether I should be using the Stereo/Mono switch. Also, which Speaker Jack to I run the speaker cable into. I have been using the 16Ohm jack in Mono. Last time my band played I had the clean volume up to 5 and it was not loud at all. Is this a sign to change my tubes? Thanks!

: Jeremy

Re: Marshal Half Stack (TSL-100)...troubleshooting help

Here is a link to the cabinet I own. It's the standard Marshall 1960 lead. I believe it is rated at 16ohms. http://www.marshallamps.com/images/products/cabinets/1960.html

Any feedback would be appreciated. Thanks!

: I kind of know what you are talking about, there are at least 2 TSL-100 factory mods one which would defintely help your problem, so should start from there to see if you have them... I'am not familiar with the cab you have but if you want to give me more info I will try to give a recommendation back.

: : Hello:
: : I own a TSL 100 with the 1960A lead cabinet. Does anyone who owns this amp know what impedance I should be using and whether I should be using the Stereo/Mono switch. Also, which Speaker Jack to I run the speaker cable into. I have been using the 16Ohm jack in Mono. Last time my band played I had the clean volume up to 5 and it was not loud at all. Is this a sign to change my tubes? Thanks!

: : Jeremy

Re: Marshal Half Stack (TSL-100)...troubleshooting help

Either of the following should work:
Option 1: ONE Speaker cable from AMP 16 Ohm output to speaker 16 Ohm input -- run speaker in MONO mode.

Option 2: TWO Speaker cables from AMP 8 Ohm outputs (make sure AMP switch is set to 8 Ohm) to Speaker 8 Ohm inputs -- run speaker in STEREO mode.

Hope this helps!

--John

Post new comment

The content of this field is kept private and will not be shown publicly.
CAPTCHA
This question is for testing whether you are a human visitor and to prevent automated spam submissions. Do not include any spaces in your answer.
Image CAPTCHA
Copy the characters (respecting upper/lower case) from the image.

Contact | Contents | Privacy Policy | Forum

This site is published by Hitsquad Pty Ltd. Copyright © 1999 - 2019 , All Rights Reserved.

Affiliate Notice: As an Amazon Associate we earn from qualifying purchases.