Help with a Bond Guitar Power Supply

I have an original Bond Electraglide.
Recently I sent it to my studio in Cape Town. Unfortunately the power supply has gone missing in the journey.
Stupidly I never paid any attention to the power supply, so do not know it's technical specification.
Can anyone help with the exact specification? If I can find out what it was I am sure I can get one made here in South Africa somewhere.
All help greatly appreciated

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

http://edge-equipment.tripod.com/id52.html

is it the yellow box? or the actual black PSU gone missing or both?

Lee
Thanks for your interest .
Both I think - sorry to sound vague but I had not used the guitar for many years (and I had only ever used it rarely) so to be honest I cannot really remember what it had. It had been lurking in the back of my studio under a desk being used as a coffee table sort of thing for ages and it was only when I packed everything up and sent everything to Cape Town that the missing power supply became apparent.
Thanks for your interest

I have the same problem of a missing power supply

Did you ever get the power supply specs? or the guitar working?

Any help on this would be great or even where I can find a power supply for sale!

Hi
Yes I did. I managed to get a supply made up - this has to be done correctly - if you send me your email I will email you the pictures etc I have.
Nigel
www.devinelie.com

csutherland97@gmail.com

Post new comment

The content of this field is kept private and will not be shown publicly.
CAPTCHA
This question is for testing whether you are a human visitor and to prevent automated spam submissions. Do not include any spaces in your answer.
Image CAPTCHA
Copy the characters (respecting upper/lower case) from the image.

Contact | Advertise | Contents | Privacy Policy | Forum

This site is published by Hitsquad Pty Ltd. Copyright © 1999 - 2017 , All Rights Reserved.