Need an Amplifier Repair Expert: Crate Amp

Posted by Alan on Sun, 04/07/02 - 01:04:47.

The question:

I have a Crate GX-80 amp. Two inputs. The inputs have stopped working. I have plugged into both inputs--no sound from either.

The speaker is working; in fact, when I jack into the "line in" input, I get full sound (but you cant control volume, tone, effects from line in). The guitar cable and jack on guitar are fine.

Any ideas on how to repair this? No amp repair people in the DC area, so I have to figure it out myself or send the damn thing (not under warranty) back to Crate.

Thanks.

Related Article:
Tube Amp Care



Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Re: Need an Amplifier Repair Expert: Crate Amp

I'm don't know anything about the GX-80 but if it's a Solid State amp then it sounds like the pre-amp is bad or a connection problem before the pre-amp. Any electronics shop (TV,Radio, VCR, etc..) should be able to repair it for you.

: The question:

: I have a Crate GX-80 amp. Two inputs. The inputs have stopped working. I have plugged into both inputs--no sound from either.

: The speaker is working; in fact, when I jack into the "line in" input, I get full sound (but you cant control volume, tone, effects from line in). The guitar cable and jack on guitar are fine.

: Any ideas on how to repair this? No amp repair people in the DC area, so I have to figure it out myself or send the damn thing (not under warranty) back to Crate.

: Thanks.

Re: Need an Amplifier Repair Expert: Crate Amp

Hi Alan,

I had a problem on a Crate GX212+ that could relate to yours. My problem was "channel hopping" - the amp would switch randomly from the dirty to the clean channel in the middle of a song! I tracked it down to the footswitch jack. The bypass contacts (jack not inserted) were dirty. Your problem could be the effects insert jack (if you have one). Try switch cleaner (squirt some in and push a jack plug in and out several times) or either replacing the faulty jack or (better if you don't use it) hard wire across it. Crate will supply a schematic if you need one. Good luck!

Paul

: I'm don't know anything about the GX-80 but if it's a Solid State amp then it sounds like the pre-amp is bad or a connection problem before the pre-amp. Any electronics shop (TV,Radio, VCR, etc..) should be able to repair it for you.

: : The question:

: : I have a Crate GX-80 amp. Two inputs. The inputs have stopped working. I have plugged into both inputs--no sound from either.

: : The speaker is working; in fact, when I jack into the "line in" input, I get full sound (but you cant control volume, tone, effects from line in). The guitar cable and jack on guitar are fine.

: : Any ideas on how to repair this? No amp repair people in the DC area, so I have to figure it out myself or send the damn thing (not under warranty) back to Crate.

: : Thanks.

Re: Need an Amplifier Repair Expert: Crate Amp

I NEED THE CRATE GX80 BLOCK DIAGRAMS

Re: Need an Amplifier Repair Expert: Crate Amp

: I'm don't know anything about the GX-80 but if it's a Solid State amp then it sounds like the pre-amp is bad or a connection problem before the pre-amp. Any electronics shop (TV,Radio, VCR, etc..) should be able to repair it for you.

: : The question:

: : I have a Crate GX-80 amp. Two inputs. The inputs have stopped working. I have plugged into both inputs--no sound from either.

: : The speaker is working; in fact, when I jack into the "line in" input, I get full sound (but you cant control volume, tone, effects from line in). The guitar cable and jack on guitar are fine.

: : Any ideas on how to repair this? No amp repair people in the DC area, so I have to figure it out myself or send the damn thing (not under warranty) back to Crate.

: : Thanks.

Re: Need an Amplifier Repair Expert: Crate Amp

: : I'm don't know anything about the GX-80 but if it's a Solid State amp then it sounds like the pre-amp is bad or a connection problem before the pre-amp. Any electronics shop (TV,Radio, VCR, etc..) should be able to repair it for you.

: : : The question:

: : : I have a Crate GX-80 amp. Two inputs. The inputs have stopped working. I have plugged into both inputs--no sound from either.

: : : The speaker is working; in fact, when I jack into the "line in" input, I get full sound (but you cant control volume, tone, effects from line in). The guitar cable and jack on guitar are fine.

: : : Any ideas on how to repair this? No amp repair people in the DC area, so I have to figure it out myself or send the damn thing (not under warranty) back to Crate.

: : : Thanks.

I just fixed my Crate GX-80 tonight. It had the same symptoms as yours. Here's the deal; the problem is the line input jack (actually all the 1/4" jacks). When nothing is plugged into the jack(s), the two metal tabs on either side of the jack are supposed to make contact with each other. The contact is made from the spring action of the metal tabs. What I did was to unsolder the jacks from the board, carefully reomove the largest metal tab, and bend it down slightly so that it makes better contact with it's "mate". After doing this, the amp was as good as new.

Re: Need an Amplifier Repair Expert: Crate Amp

All of these are common symtoms and solutions to your problem, but if anything I have noticed it was how bad the soldering was on my jacks leads they were cracket ad caused the jack itself to almost fall out of the unit onto the ground, I ended up sacrificing a lesser important input jack I think my line out or something and resoldered it the correct way and it is almost finished being repaired

Re: Need an Amplifier Repair Expert: Crate Amp

Please god help me. I recently paid $240 for an unused crate dx112w. It's played absolutely brilliantly for the past week until last week when, whilst swithing it on it just turned itself off again. Now i don't get any power or even any light in the "digital" sign. Absolutely nothing. I'm totally distraught because obviously now the amp has passed from the original owners hands the warranty is void. Please help me...

Re: Need an Amplifier Repair Expert: Crate Amp

: The question: I HAVE A CRATE GFX
120 AND THE AMP WORKS FINE FOR A LITTLE WHILE. THEN, I GUESS AFTER IT HEATS UP IT MAKES KIND OF A POPPING SOUND THEN GOES INTO A LOW END BUZZ AND I CAN'T PLAY.
I THEN TURN OFF THE AMP AND WAIT A WHILE. WHEN I TURN IT BACK ON IT'S FINE. IF YOU KNOW OF ANY WAY TO REPAIR THIS I WOULD GREATLY APPRECIATE IT.

THANK YOU

Crate V100H tube amp

I have a Crate V100H 100 watt tube amp...it lights up, but no sound whatsoever...any ideas...

Thanks, Ollie

crate V100h repaired

I have a Crate V100h that had the same symptom, panel light was on but not much output from the SMPS. It took me awhile to figure out with my 1970s electronics training. I was about to retrofit it to a traditional power transformer but ones with a 15V+ and - outputs are very expensive. After learning how a switch mode works, on mine, I located and replaced a shorted rectifier diode in one of the 15V outputs and the amp came back to life. If there is a fault in one of the outputs, the logic chip pretty much shuts the power supply down. I'm still working on a tweek to fix the crappy tone these have in their high gain channel. Maybe changing a capicator value in the right location. If anyone ever reads this and has a solution, I'd love to hear it.

Post new comment

The content of this field is kept private and will not be shown publicly.
CAPTCHA
This question is for testing whether you are a human visitor and to prevent automated spam submissions. Do not include any spaces in your answer.
Image CAPTCHA
Copy the characters (respecting upper/lower case) from the image.

Contact | Contents | Privacy Policy | Forum

This site is published by Hitsquad Pty Ltd. Copyright © 1999 - 2021 , All Rights Reserved.

Affiliate Notice: As an Amazon Associate we earn from qualifying purchases.