ampeg svt-3 pro crashdown

Posted by saso krizman on Wed, 04/24/02 - 15:07:34.

hi.

I kinda hope you can help me with this:
recently i got my hands on an Ampeg svt-3 pro but it has a problem.
Sometimes it would start OK, however, it has certain
breakdown problems which go like this:
Normally, the fan starts at high speed and slows down
a bit, and after about 10 - 12 seconds the output relay
clicks and the amp is ready to use.

In my case, the fan starts at high speed, slows down, but the relay switches on and off (collapses) after just a few seconds, and after this has been going on for a few more seconds, the main fuse blows, sometimes even the automatic fuse for the entire house section will blow and will need to be reset prior to any
other tinkering.

What should i check (lamps, 450WV capacitors, the output capacitors, or something else perhaps)?

Without a schematic, i'm as blind as a wall trying to fix this, so can you also suggest me a site which has Ampeg SVT-3 PRO schematic as i've been surfin' round
the web with little or no success in this field.

Thanks a lot.

SASO (fade13fade@yahoo.com)



Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Re: ampeg svt-3 pro crashdown

the fan circuit detects that you have a higher temperature....write and i wil help you...
i need to know the secondaries ac voltages of the toroidal transformer cause my svt ii pro main ac is totally damged

Post new comment

The content of this field is kept private and will not be shown publicly.
CAPTCHA
This question is for testing whether you are a human visitor and to prevent automated spam submissions. Do not include any spaces in your answer.
Image CAPTCHA
Copy the characters (respecting upper/lower case) from the image.

Contact | Contents | Privacy Policy | Forum

This site is published by Hitsquad Pty Ltd. Copyright © 1999 - 2022 , All Rights Reserved.

Affiliate Notice: As an Amazon Associate we earn from qualifying purchases.