fender amp fuse keeps blowing

Posted by aceiommi on Sat, 01/22/05 - 12:45:39.

As soon as i turn on my fender amp the power fuse keeps blowing what's wrong with this? and how or what can i do to fix it? any suggestions will be deeply appreciated!!! rock on!!

Related News:
Fender '65 Super Reverb FSR Guitar Amp
Fender G-DEC 3 Amplifier

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Re: fender amp fuse keeps blowing

are you sure you are using the correct type of fuse? the correct rating? try plugging the amp into a seperate mains supply, try your friends house, change the power cable, if its a kettle type lead you can do this, check the wiring inside the plug, has the earth come loose? try a different power outlet, if all this fails i would take it to a dealer.

Re: fender amp fuse keeps blowing

1. Make sure you are using the correct fuse, if it says Slo Blo the use Slo Blo, get some spares.

2. Pull your Tubes, Turn it on, If it blows the (correct) fuse then take it to a Tech (deal directly with the repair shop, not a middle man). If the fuse does not blow, reinstall your preamp tubes, if it doesn't blow then you've isolated it to your power tubes. You can reinstall them and see if it blows again or get some more tubes.

Post new comment

The content of this field is kept private and will not be shown publicly.
CAPTCHA
This question is for testing whether you are a human visitor and to prevent automated spam submissions. Do not include any spaces in your answer.
Image CAPTCHA
Copy the characters (respecting upper/lower case) from the image.

Contact | Contents | Privacy Policy | Forum

This site is published by Hitsquad Pty Ltd. Copyright © 1999 - 2017 , All Rights Reserved.