Guitarsite Forums Guitar Discussion Guitar Help with a Bond Guitar Power Supply

  • Creator
    Topic
  • #22845
    Nigel
    Participant

    I have an original Bond Electraglide.
    Recently I sent it to my studio in Cape Town. Unfortunately the power supply has gone missing in the journey.
    Stupidly I never paid any attention to the power supply, so do not know it’s technical specification.
    Can anyone help with the exact specification? If I can find out what it was I am sure I can get one made here in South Africa somewhere.
    All help greatly appreciated

Viewing 4 reply threads
  • Author
    Replies
    • #126676
      cs97
      Participant
    • #126675
      Nigel
      Participant

      Hi
      Yes I did. I managed to get a supply made up – this has to be done correctly – if you send me your email I will email you the pictures etc I have.
      Nigel
      http://www.devinelie.com

    • #126674
      cs97
      Participant

      I have the same problem of a missing power supply

      Did you ever get the power supply specs? or the guitar working?

      Any help on this would be great or even where I can find a power supply for sale!

    • #76201
      Nigel
      Participant

      Lee
      Thanks for your interest .
      Both I think – sorry to sound vague but I had not used the guitar for many years (and I had only ever used it rarely) so to be honest I cannot really remember what it had. It had been lurking in the back of my studio under a desk being used as a coffee table sort of thing for ages and it was only when I packed everything up and sent everything to Cape Town that the missing power supply became apparent.
      Thanks for your interest

    • #76213
      lee_UK
      Participant

      http://edge-equipment.tripod.com/id52.html

      is it the yellow box? or the actual black PSU gone missing or both?

Viewing 4 reply threads
  • You must be logged in to reply to this topic.