Home Forums Discussion Popular Topics RP2000 Problem. Anybody else?

  • Creator
    Topic
  • #19769
    Anonymous
    Guest

    My RP2000 bit the dust a couple days ago. I went to power it up, and the display went into gibberish(some weird punctuation type marks,and "50"). I tried resetting, which eventually worked(once), but it keeps going back to locking up,and display goes wacky. Anybody else have this problem? Is there a website (other than digitech’s) that would be helpful? I am fluent with a soldering iron/station,and know how to test Q’s diodes,resistors etc.,and found no problem. This thing has a lot of smd’s and ic’s,which I’m not fluent with. Thanks for any help. Rob

Viewing 3 reply threads
  • Author
    Replies
    • #79608
      Anonymous
      Guest

      Where can I get a replacement Internal replacement battery?

    • #78772
      Anonymous
      Guest

      Mine started acting weird. Only way to get it to work is to factory reset it every power up. Problem was that the internal battery was dead. Replaced the battery and it’s all good again.

      Replacing the battery is a little bit of a chore. Mine was soldered in. You’ll have to lift the main board to get to the other side so you can remove the solder off the board to loosen the battery. I decided to install a battery holder so that next time, I just snap out the battery and insert a new one. The board was designed for a holder, so that was simple.

      Good luck

    • #89904
      Anonymous
      Guest

      If you mean RP 200; I have one myself, it broke down a month after I bought it. The guy at the music store said the memory was scrambled( i don’t know what it means) but try reseting to the factory setting. Else you’d end up paying 50 dollars like me. : My RP2000 bit the dust a couple days ago. I went to power it up, and the display went into gibberish(some weird punctuation type marks,and "50"). I tried resetting, which eventually worked(once), but it keeps going back to locking up,and display goes wacky. Anybody else have this problem? Is there a website (other than digitech’s) that would be helpful? I am fluent with a soldering iron/station,and know how to test Q’s diodes,resistors etc.,and found no problem. This thing has a lot of smd’s and ic’s,which I’m not fluent with. Thanks for any help. Rob

    • #89127
      Anonymous
      Guest

      Have you tried using the software reset for it? Check the manual for the proper button sequence (it’s online at digitech.com if your manual isn’t handy.) : My RP2000 bit the dust a couple days ago. I went to power it up, and the display went into gibberish(some weird punctuation type marks,and "50"). I tried resetting, which eventually worked(once), but it keeps going back to locking up,and display goes wacky. Anybody else have this problem? Is there a website (other than digitech’s) that would be helpful? I am fluent with a soldering iron/station,and know how to test Q’s diodes,resistors etc.,and found no problem. This thing has a lot of smd’s and ic’s,which I’m not fluent with. Thanks for any help. Rob

      • #109506
        Anonymous
        Guest

        : Have you tried using the software reset for it? Check the manual for the proper button sequence (it’s online at digitech.com if your manual isn’t handy.) Yeah, I have performed the hard reset procedure, which didn’t seem to help at first, but I tried it again since, and everything seems fine now. The E-PROM may be getting unstable. I wonder if the upgraded one would be a permanent fix??? Thanks for the input, Rob

Viewing 3 reply threads
  • You must be logged in to reply to this topic.